注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

SunOfMay的博客

At.163

 
 
 

日志

 
 

liferay 启动提示 An incompatible version 1.1.14 of the APR based Apache Tomcat Native library is installed  

2013-10-28 13:53:03|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

liferay6.1 在启动时提示:

An incompatible version 1.1.14 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.17

原因:

apr的文件版本不对.

解决办法:

http://archive.apache.org/dist/tomcat/tomcat-connectors/native/?C=M;O=D
下载tcnative-1.dll这个文件, 放到\liferay-portal-6.1.1-ce-ga2\tomcat-7.0.27\jre1.6.0_20\win\bin目录下, 解决问题.

说明:
目前tcnative-1.dll文件版本更新最大到1.1.22, 后面就通过其他方式使用了, 下载时需要留意.

其他情况根据eclipse配置jdk, tomcat的目录情况, 可以参考下面文章解决问题. 本文亦受下文启发.

http://hi.baidu.com/dragonqs/item/058b02d900263f3d48e1ddb4

 

菊子曰 你玩微博么?写博客么?强力推荐你试试菊子曰
  评论这张
 
阅读(340)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018